After a new Topology install, getting error Topology "Graph service is unavailable"
search cancel

After a new Topology install, getting error Topology "Graph service is unavailable"

book

Article ID: 441304

calendar_today

Updated On:

Products

Network Observability

Issue/Introduction

Did a fresh install of Topology.

Users encounter a "Graph service is unavailable" error or an "inventory data failed to synchronize" error when attempting to run a Sync under Topology Configuration in DX NetOps. 

 

the install logs show "Neo4J1" errors like this:

fatal: [Neo4J1]: FAILED! => {
    "attempts": 6,
    "censored": "the output has been hidden due to the fact that 'no_log: true' was specified for this result",
    "changed": true

Environment

NetOps Topology 25.4.x

New install

Cause

Port conflict on port 5000 prior to the install.

See the Topology Prerequisites here:

Deployment Overview of Topology

The customer had another application causing a conflict on pot 5000.  However, they are unable to configure the other application to use a different port.

Resolution

-Use the following command to remove the failed topology install

ansible-playbook -i inventory -K topology-uninstall.yaml

-After removing Topology, temporarily stop the conflicting application in order to free up port 5000.

-Reinstall Topology

-After the install is complete, change the  Neo4J port by following the steps from the following KB:

How to change the port that the Neo4j service uses after installing the DX NetOps Topology services?

On the ansible host, run the following command to stop the services.

ansible-playbook -i inventory -K provisioning/services_stop.yaml

On the topology host, open the <install_directory>/netops-topology/neo4j/conf/neo4j.conf file and add the below to the bottom of the file:

server.discovery.listen_address=:5001
server.discovery.advertised_address=:5001

Save the file and then run the below command back on the ansible host to start the services.

ansible-playbook -i inventory -K provisioning/services_start.yaml

 

-Reboot the server and restart the other application that runs on port 5000