VNA Plugin for Versa – Performance Polling Interval Mismatch with data shown at 30 min resolution instead of 15
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VNA Plugin for Versa – Performance Polling Interval Mismatch with data shown at 30 min resolution instead of 15

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Article ID: 441170

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

We have configured the performance polling interval and delta time to 15 minutes for Versa performance data collection. However, we are observing that the metrics are being collected at an interval of approximately 30 minutes instead of the expected 15 minutes and shown as such in the DX NetOps Portal GUI dashboards and reports.

Configuration details are:  

PERFORMANCE_POLL_RATE: "0 */15 *"
PERFORMANCE_DELTA_TIME: 900

Expected: Metrics collected every 15 minutes,
Actual  : Metrics collected every ~30 minutes

Environment

DX NetOps CAPM integrated with VNA all currently supported releases

Cause

VNA polls at 15 min intervals and currently Versa Controller provides metrics at 15 min delta.

If the Versa Controller provides data at 15min intervals, then VNA VERSA plugin sends that to CAPM and it will be recorded in the DB at 15 min intervals.

As such, we can override the Portal setting which defaults to 30min resolution for time periods greater than 4 hours by setting Model.OverrideSDWanResolution = True. This setting means we can show data at 15m resolution after 4 hours in the Portal GUI reports if the data is in the DB at 15m.

Resolution

To modify the attribute controlling the data resolution shown in the Portal GUI, you can set the Model.OverrideSDWanResolution in the Portal PC->General table to 'true'. There are two ways to do this:

Option 1

  1. login to the Portal command line and cd /opt/CA/MySql/bin

    NOTE: your MySql directory maybe different, the above is default path

  2. login to netqosportal MySql DB; 

    ./mysql -unetqos -p<PASSWORD> netqosportal

  3. Run the following;

    insert into netqosportal.general values('Model.OverrideSDWanResolution', 'true');


Option 2

  1. You can also change it in the PC -> Global Attributes Debug page, accessible via:

    http://[NetOps_Portal_hostname_or_IP]:8181/pc/center/admin/debug/attrs


  2. You can change Model.OverrideSDWanResolution in there to true and then click on the Update button. The page looks like: