Error: "Cannot find available cloud zones" when deploying virtual machines in VMware Aria Automation with VCF-enabled vCenter
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Error: "Cannot find available cloud zones" when deploying virtual machines in VMware Aria Automation with VCF-enabled vCenter

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Article ID: 441123

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When attempting to deploy virtual machines in VMware Aria Automation, the provisioning process fails with the following error:

Cannot find available cloud zones in the current project. Maybe there is no connectivity to the endpoint(s).

Additionally, inspecting the cloud account reveals the following health check warning: Endpoint validation failed during health check: FAILED with Failed to validate.. Original Task Error: 'Failed to validate.

The Update Cloud Account Certificate workflow utilized in KB 318756 was attempted, but still having issues.

Environment

Aria Automation 8.18.1

vCenter 8.0U3 VCF-enabled (vCenter was moved from a VCF 5 instance to a VCF 9 instance)

Cause

The Update Cloud Account Certificate workflow utilized in KB 318756 to update the cloud account is incompatible with VCF-enabled vCenter environments.

Resolution

To resolve this issue, you must bypass the standard workflow and apply the configuration directly using the API.

  1. Open a support request to go over internal steps of KB 318756.
  2. Execute the API calls against the VMware Aria Automation environment as specified to update the cloud account successfully.

  3. Verify that the cloud account health check now passes and the cloud zones are available.