Find Version fails to locate files when using Case Sensitive search in CA Harvest 14.5.1
search cancel

Find Version fails to locate files when using Case Sensitive search in CA Harvest 14.5.1

book

Article ID: 441071

calendar_today

Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

After upgrading to CA Harvest Software Change Manager (SCM) version 14.5.1, the "Find Version" function in the Workbench client fails to locate files when a case-sensitive search is performed.

Specific name patterns (e.g. patterns like `PEL_HR_CHECK*`) do not return expected results even if matching files exist.

The same operation works as expected in previous CA Harvest versions, like version 13.0.x.

Environment

CA Harvest Software Change Manager (SCM) 14.5.1

Upgraded from a previous prior to 14.x

Cause

The "Case sensitive" toggle in the "Find Version" dialog does not correctly handle filename patterns

Resolution

A test fix is available to resolve this behavior and is attached to this article

  1.  Follow the specific instructions provided within the 'Instructions_Efix.txt' file contained in the ZIP file
  2. Make sure to restart  CA Harvest Workbench
  3.  Verify that the "Find Version" function now correctly identifies files when the "Case sensitive" option is engaged

If the issue still persists, please contact Broadcom Support.

Attachments

CaseSensitiveFindVersionDialog.zip get_app