After upgrade of CA Performance Management (CAPM), daemon will not stay up and running, fails within a few seconds.
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After upgrade of CA Performance Management (CAPM), daemon will not stay up and running, fails within a few seconds.

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Article ID: 441012

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

After upgrading to 25.4.x from 24.3.x, the DA, DR and Portal all report that they are successfully upgraded. DR starts with Vertica running. However, when starting the DA (systemctl start dadaemon), it fails within seconds.

Environment

DX NetOps CAPM upgrade to 25.4.x or later from 24.3.x and prior versions.

Cause

Looking in the DA process log, /opt/CA/IMDataAggregator/data/logs/netops-data-aggregator.log, we see the following error:

Error starting ApplicationContext. To display the condition evaluation report re-run your application with 'debug' enabled.
2026-05-20T01:40:11.853 | ERROR | main        | SpringApplication | framework.boot.SpringApplication 857 | - - | | Application run failed org.springframework.context.ApplicationContextException: Unable to start web server
      at org.springframework.boot.web.servlet.context.ServletwebserverApplicationContext.onRefresh(ServletwebServerApplicationContext.java:170)
      at orq.springframework.boot.web.server.WebServerException:  Unable to create tempDir. iava.io.tmpdir is set to /opt/CA/tmp

The DA Tomcat web server is failing to start due to an inability to create a temp file in the specified directory required during the startup process. In this case, the dadaemon start script is unable to create the directory /opt/CA/tmp.

 

Resolution

The directory already exists and has contents, so it needs to be removed as the start script cannot use a currently existing directory. Once removed (in this example - /opt/CA/tmp), you should be able to start.