Intermittent network disconnects on virtual machines using Cisco ACI VMM integration
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Intermittent network disconnects on virtual machines using Cisco ACI VMM integration

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Article ID: 440950

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You may experience intermittent network disconnects between app servers and DB servers, while there is no total network disconnection for the VM.
  • The VM's are on vLAN backed segments and NSX isn't used for networking as there are no edges deployed.
  • This issue persists even after adding the affected virtual machines to the Distributed Firewall (DFW) exclusion list or completely shutting down the DFW.
  • You are using an ACI management integrations (ACI VMM integrated dvs) through vSphere and NSX-T Public APIs.

Environment

VMware NSX
VMware vSphere ESXi

Cause

  • The virtual machines are utilizing VLANs on a Distributed Virtual Switch (DVS) managed by a Cisco ACI VMM integration.
  • Cisco ACI VMM integration is a partner integration that has no clear demarcation point. Due to the operational nature of this integration, Broadcom requires issues to be reproduced in an environment free of the partner component to confirm if the root cause lies within vSphere or NSX.

Resolution

Broadcom support desires a demarcation point to effectuate changes on the distributed switch without affecting other infrastructure switching and connectivity. This demarcation point is required to avoid causing a customer to experience a distorted configuration between the vSphere distributed virtual switch and the control and data planes of a partner switch when manipulating the distributed switch to troubleshoot issues. Most automation tools do not create a configuration link between the vSphere distributed switch and the physical switches. 

In cases where there is no clear demarcation line,* Broadcom will require the following two steps to troubleshoot or manage issues related to vSphere, NSX-T, or NSX environments. Broadcom will request the creation of an environment free of the partner component in question** for troubleshooting purposes.

  • If the issue is reproducible without the partner component, Broadcom will support and investigate as normal.
  • If the issue is not reproducible after removing the partner component, Broadcom will not investigate further. At this point, Customer Support at the partner should be contacted.

*One such partner integration that has no clear demarcation point is the Cisco ACI VMM integration and other related Cisco ACI integrations leveraging the vSphere and NSX-T APIs. Due to the operational nature this integration, Broadcom will require the steps described above to troubleshoot the issue.

Additional Information

VMware KB: VMware Support for Partner management integrations through vSphere and NSX-T Public APIs
Cisco document: Cisco ACI VMM (VMware DVS, NSX-T & AVE) Integration Support in a VMware Environment