"Could not retrieve email address for the recipients" error received when configuring email server for VCF Automation
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"Could not retrieve email address for the recipients" error received when configuring email server for VCF Automation

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Article ID: 440511

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Updated On:

Products

VCF Automation

Issue/Introduction

  • When configuring email server for VCF Automation, below error is received after entering the information for all required fields. As a result of this error, the email server configuration cannot be saved, which impacts email notification functionality.

    Could not retrieve email address for the recipients <logged-in user>.

  • This happens even if the same email server has been successfully configured and proven functional for other components, such as VCF Operations.

Environment

VCF Automation 9.x

Cause

This issue occurs because the currently logged-in VCF Automation user account does not have an email address associated with its account profile. The system requires the configuring user to have a valid email address to complete the setup.

Resolution

To resolve this issue, the logged-in user must add an email address to their profile before saving the configuration. Steps to follow:

  1. Login to VCF Automation.
  2. Navigate to My Account.
  3. Add a valid email address in the email field and apply the changes.
  4. Return to the email server configuration page. Click Test Connection for the configured email server. Once the connection is successfully validated, save the configuration.

Additional Information

The following document can be followed to configure email server in VCF Automation: Add an email server in VCF Automation to send notifications.