"One or more vCenter instances are not connected to a License Server" after upgrading to 9.1.0
search cancel

"One or more vCenter instances are not connected to a License Server" after upgrading to 9.1.0

book

Article ID: 440471

calendar_today

Updated On:

Products

VMware vCenter Server VMware Cloud Foundation VMware vSphere Foundation VCF Operations

Issue/Introduction

  • License assignment fails after upgrading vCenter from 9.0.x to 9.1.0.
  • vSphere Client shows the warning banner with error message "One or more vCenter instances are not connected to a license server. To avoid service interruption, verify that the vCenter instance is connected to a license server."



  • VCF Operations shows License sync errors as below:
    • "Licenses could not be synchronized with the vCenter systems."
    • "Licenses could not be assigned to the vCenter system. Please try again or check the error logs."

Environment

  • vCenter 9.1.0
  • VMware vSphere Foundation (VVF) 9.1.0
  • VMware Cloud Foundation (VCF) 9.1.0

Cause

  • VMware Cloud Foundation (VCF) or VMware vSphere Foundation (VVF) 9.1 introduces a License Server component for license management operations.
  • Licensing through vCenter is impossible until the License Server is deployed within VCF Management Services.
  • This issue is observed if the 9.1 upgrade is not performed in the specified order and the License Server component is not installed.

Resolution

  1. Upgrade VCF Operations to version 9.1 via a PAK file, follow the instructions in Upgrading to VCF Operations 9.1.
  2. Deploy VCF Management Services and License Server by following instructions in Deploy VCF Management Services and License Server for vSphere Foundation.
  3. Register License Server and assign licenses by following the instructions in Licensing Overview.

Additional Information

Refer the following documents for VVF and VCF upgrade order to 9.1.