Login to HCX 443 UI fails with "Authentication failed with ViDB OIDC AutCode" with VCF SSO
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Login to HCX 443 UI fails with "Authentication failed with ViDB OIDC AutCode" with VCF SSO

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Article ID: 440377

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Updated On:

Products

VMware HCX

Issue/Introduction

  • Logging into the HCX manager UI port 443 via VCF SSO integrated, displays the following error=following error message:

        "Authentication failed with ViDB OIDC AuthCode"

       

 

Environment

VMware HCX

Cause

  • HCX has a default maxHttpHeaderSize of 8KB.
  • When using VCF SSO, the access tokens issued by vIDB are Base64 encoded within the HCX component.
  • This encoding increases the header size, often exceeding the 8KB limit, thus causing authentication to fail.

Resolution

Increase the HTTP header size limit on the HCX Manager appliance:

  • SSH to the HCX Manager Appliance VM as root.

  • Navigate to the folder
    cd /opt/vmware/config/web-engine/

  • Take a backup of the existing file
    cp application.properties bk-application.properties-old
  • Open the following file for editing:
    vi application.properties
  • Add the following property to the file and save it.
    server.max-http-header-size=65536

  • Restart the web engine service:
    systemctl restart web-engine
  • Try to login to the HCX manager.

Additional Information

If you believe you have encountered this issue, open a support case with Broadcom Support and refer to this KB article.
For more information, see Creating and managing Broadcom support cases.

If you are contacting Broadcom support about this issue, please provide the following:

  • HCX On-Prem Support Bundle
  • HCX Cloud Support Bundle

Refer to the documentation to download the HCX support bundle Gather Technical Support Logs