Error "ORA-12546: TNS:permission denied" is seen when trying to make a connection to the Oracle Database from Enforce
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Error "ORA-12546: TNS:permission denied" is seen when trying to make a connection to the Oracle Database from Enforce

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Article ID: 440269

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Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

When connecting to the Protect DB instance on Oracle using sqlplus, we see the error "ORA-12546: TNS:permission denied".

Cause

This is caused by OS/Network related issues blocking the connection to the database.

Resolution

First to verify the issue try the following steps:

  1. Open CMD in administrator mode.
  2. Open JDBC.properties file and copy everything after the equal sign that holds the connection string including server and port and service_name.  The line will look like "jdbc.dbalias.oracle-thin=@(description=(address=(host=OracleServer)(protocol=tcp)(port=1521))(connect_data=(service_name=protect)))"
  3. Type 'sqlplus /nolog'\
  4. Type 'username@connection string' Example: connect protect@(description=(address=(host=OracleServer)(protocol=tcp)(port=1521))(connect_data=(service_name=protect)))
  5. Type in the password for the protect user.
  6. You should see "ORA-12546: TNS:permission denied" in CMD.
  7. Now try the same test on the Oracle server itself and it should connect fine.

 

This issue only happens from the client side connecting to the DB server itself.  This is caused by OS/Network related issues blocking the connection to the Database.  Please check no security software is blocking this connection, or no network firewall is blocking anything.