Error: "Your Single Sign-On attempt failed" when using vIDM as OAUTH2 client for OIDC setup in VCFA "All Apps" org
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Article ID: 440245
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Updated On:
Products
VCF Operations/Automation (formerly VMware Aria Suite)
Issue/Introduction
- vIDM is configured as the IdP under OIDC in VCFA
- Users/groups are added in the Access Control screen
- The redirect to vIDM and login works correctly but when the browser is redirected back to VCFA we get the message "Your Single Sign-On attempt failed"
- This may be working correctly for "VM Apps" org
Environment
- VMware Cloud Foundation Automation 9.0.x
- VMware Identity Manager 3.3.7
Cause
In VCFA "All Apps" (modern tenancy), vIDM is not supported as an Identity Provider
Resolution
There are other options available for IdP setup:
- Use vIDB as the identity provider to make use of VCF-SSO
- Make a direct connection to the OIDC provider without using vIDM / vIDB
- Use the SAML option to connect to an IdP
Feedback
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Yes
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No