Unable to change HCX MON router because VM is not visible under the Network Extension tab
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Unable to change HCX MON router because VM is not visible under the Network Extension tab

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Article ID: 440222

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Updated On:

Products

VMware HCX

Issue/Introduction

  • You are unable to modify the Target Router Location (changing the MON router) because the VM is missing from the Network Extension -> Mobility Optimized Networking (MON) view.
  • The VMs are present in the vCenter inventory but fail to populate within the HCX management interface.
  • The following error are observed in /common/logs/admin/app.log:
    <timestamps> UTC [TopologyService_SvcThread-1129949, Ent: HybridityAdmin, , TxId: ########-####-####-####-############] ERROR c.v.v.h.v.GenericVsphereInFrequentPoller- Error Queuing GenericVsphereInFrequentPoller Job on retry. System appears to be in stress. Retrying again
    java.lang.RuntimeException: Error performing pre-queue for Job: Workflow vsphereJobs/GenericVsphereInFrequentPoller job (########-####-####-####-############ ) State:BEGIN PrevState:UNDEFINED_STATE called by Service:TopologyService

Environment

VMware HCX

Cause

This issue is caused by resource contention (memory starvation and high CPU utilization) on the HCX Manager appliance.

The default resource allocation of 4 vCPUs and 12 GB RAM is designed to support a maximum of 400 VMs with MON enabled.

Operating above these scalability limits causes the manager to enter a "stress" state.
In this state, the internal PostgreSQL database becomes unable to process inventory synchronization queries, causing background jobs like the GenericVsphereInFrequentPoller to fail. Consequently, newly migrated or existing VMs fail to populate in the HCX inventory, preventing any MON-related configuration changes.

Resolution

Ensure you are running a supported configuration for MON-enabled VMs. For more information, please access: HCX Mobility Optimized Networking (MON) Scalability Guide.
If your environment is below the maximum supported limit, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.