Error "java.rmi.RemoteException: Timed out trying to connect to test registry" while connecting from Workstation
search cancel

Error "java.rmi.RemoteException: Timed out trying to connect to test registry" while connecting from Workstation

book

Article ID: 4402

calendar_today

Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder)

Issue/Introduction

Seeing the error below in workstation while connecting to the registry: 

java.rmi.RemoteException: Timed out trying to connect to test registry tcp://Servername:2010/Registry 

Environment

Release: DevTest 10.7.2 or newer

Cause

The latency from local machine to Registry and LIVE system is high

The recommended turnaround time from any component to Registry's DB is less than 20ms. If the network latency is higher than this, there could be such Timed out errors. 

Resolution

Reduce the network latency to DB to keep it below 20ms. 

Enabling the properties below in local.properties will help as a workaround 

lisa.http.timeout.connection=0 
lisa.http.timeout.socket=0 

This sets the waiting time to indefinite.

 

Additional Information

https://knowledge.broadcom.com/external/article/9872/devtest-environmental-restrictions.html