DXO2 data ingestion failure: restmon utility fails to start due to port conflict.
search cancel

DXO2 data ingestion failure: restmon utility fails to start due to port conflict.

book

Article ID: 440199

calendar_today

Updated On:

Products

DX SaaS DX Operational Observability

Issue/Introduction

Alarms and metrics from integrated monitoring tools (e.g., SolarWinds) fail to ingest into the DX SaaS (DXO2) tenant. Upon investigation, data ingestion is halted because the restmon utility is offline and fails to initialize.
Checking the restmon log following has been captured:

[main] ERROR LoggingFailureAnalysisReporter:40

***************************
APPLICATION FAILED TO START
***************************

Description:

Web server failed to start. Port ### was already in use.

Cause

A port conflict on the host machine is preventing the application from starting.

Resolution

Release occupied port or assign new one following procedure.