Incorrect uptime calculation for downtime availability report
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Incorrect uptime calculation for downtime availability report

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Article ID: 440155

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

The downtime availability report  (All Events / Events by Category / Downtime Calculation / Availability by Component)  may incorrectly display 100% uptime for some components, even when significant downtime has occurred.

Environment

Watch4net|M&R 7.9.0.0 and prior versions

Cause

This issue is caused by the rounding behavior of the DurationDiv value within the M&R framework. By default, this value is stored with 4 decimal places.

  • When the 5th decimal place is less than 5, the value is rounded down (e.g., [HOSTNAME] → 0.0000).
  • When the 5th decimal place is greater than 5, the 4th decimal place is rounded up (e.g., [HOSTNAME] → 0.0001).

Due to this precision limit, higher downtime values can be rounded down to zero, incorrectly resulting in a calculated uptime of 100%

Resolution

The issue is resolved by increasing the decimal precision from 4 to 6 places. This fix will be officially included in M&R version 7.9.0.1. Broadcom recommends upgrading to this version or later to resolve the issue.