Expand Cluster fails with Incompatible Disk Size
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Expand Cluster fails with Incompatible Disk Size

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Article ID: 440110

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

When performing an "Expand Cluster" operation to add a new platform node to an existing cluster, The cluster expansion task fails with a disk size incompatibility error as seen in the following example:

The platform (IP [##.##.##.###]), disk size[1024]) is not compatible with the [Error] existing platform (IP [##.##.##.###], disk size[3686]). Deploy new platforms with the same disk size as the existing platform or add an additional disk that corresponds to that size and retry creating or expanding the cluster.

Additional symptoms include:

  • The clustering action times out.
  • The new node is not added to the cluster.
  •  "vmware_vrlcm.log" (if using Aria Suite Lifecycle Manager) may report error code "LCMVRNICONFIG90061".

Environment

VCF Operations for Networks 6.x

Cause

The newly deployed platform node was provisioned with the default disk capacity of 1024 GB (1 TB). This does not match the disk capacity of the existing cluster nodes, which have been expanded to a larger size (e.g., 3686 GB or 3.4 TB). The cluster expansion validation process requires uniform disk capacities across all participating platform nodes.

Resolution

To resolve this issue, the disk size of the new node must be aligned with the existing cluster nodes before the expansion process is finalized.

  1. Delete the failed or partially deployed platform node from the vCenter inventory.

    Caution: Only delete a platform node if the clustering did not complete. Unrepairable damage occurs if a clustered node is deleted.

  2. Deploy a new platform node using the same brick size (e.g., XL) as the existing cluster.
  3. Before adding the node to the cluster, add new disk(s) to the new VM in vCenter so that space of all disks added when totaled match exactly the total disk space of the existing node (e.g., 3686 GB).

    Note: Refer to the product documentation for "Increase the Disk Size" to ensure additional disks are integrated correctly into the logical volume.

  4. Ensure the VCF Operations for Networks cluster is in a healthy state and a valid backup or snapshot has been taken.

    See Best practices to shutdown VCF Operations for Networks Clustered deployments.

  5. Retry the Expand or Scale Out Clusters procedure from the Infrastructure and Updates page in the GUI.

Once the disk sizes match exactly, the pre-condition checks will pass, allowing the cluster to expand successfully.