Tanzu Hub Foundation Vending failing on Extract Files step due to insufficient disk space on Blobstore VM
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Tanzu Hub Foundation Vending failing on Extract Files step due to insufficient disk space on Blobstore VM

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Article ID: 440053

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Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

  • When attempting to create a new Foundation from Tanzu Hub 10.4, you see the "Extract files from a downloaded file into remote storage" retried until failure:



  • The Tanzu Hub is deployed in Evaluation Mode.


  • The graphql-rest-provider-service pod logs show errors like:
    06:14:59.895Z [thread='Activity Executor taskQueue="tanzu-local-worker-task-queue", namespace="default": 1' user='' org='' trace=''] WARN io.temporal.internal.activity.ActivityTaskExecutors$ActivityTaskExecutor - Activity failure. ActivityId=########-####-####-####-f7330633d78f, activityType=Monitoring Foundation Core appliance download status, attempt=2
    io.temporal.failure.ApplicationFailure: message='ops-manager download did not complete after 50 retries', type='ops-manager_DOWNLOAD_WORKFLOW_TIMEOUT'

Environment

Tanzu Hub 10.4 release running in Evaluation Mode.

Cause

The graphql-rest-provider-service deployment depends on the Blobstore VM to send files to for storage. In Evaluation Mode, the Blobstore VM is configured with 100 GB, which might be insufficient for certain operations, like foundation vending. This may lead to extract failures during foundation vending operations and the reported Download failures. 

Resolution

Increase Blobstore VM to 300GB persistent disk and Apply changes then try the Foundation Vending operation again.