Error "Invalid redirect URL" when logging in to VCF Operations using VCF SSO
search cancel

Error "Invalid redirect URL" when logging in to VCF Operations using VCF SSO

book

Article ID: 439953

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • When attempting to log in to VCF Operations using VCF SSO, an error is received.
  • Error
    VCF Identity Broker encountered an issue during authentication.
    Please contact your VCF Admin with the below details for resolution.
    
    Message
    Invalid redirect URL https://[vcf-ops-fqdn]/ui/vidbClient/vidb/ specified in authorize request
    
    error code
    oauth2.request.invalid.redirecturl
  • There is not an external load balancer in use.
  • The VCF Operations cluster was recently re-IP'd

Environment

  • VCF Operations 9.0.x
  • VCF Identity Broker 9.0.x

 

Cause

The redirect URL list has become out of sync with the VCF Operations cluster.

Resolution

  1. Log in to VCF Operations UI with the local admin user
  2. Navigate to Fleet Management > Lifecycle > VCF Management > Components
  3. Click Manage next to the operations component
  4. Click Trigger Inventory Sync
  5. After the Inventory Sync task completes successfully, log out of VCF Operations and attempt the VCF SSO login again 

Additional Information

To view the list of currently configured redirect targets:

  1. Navigate in the browser to https://<vcf-operations-primary-node-fqdn>/casa/sysadmin/cluster/config/addresses
    (replace <vcf-operations-primary-node-fqdn> with the FQDN of the primary node in the VCF Operations cluster)

    Example:
    https://ops-a.example.com/casa/sysadmin/cluster/config/addresses
  2. Provide the VCF Operations admin user and password when prompted
  3. Review the JSON results which will list all currently allowed redirect targets
    Example:
    {"nodes":[{"uuid":"1a2b####-####-####-########3c4d","sliceName":"ops-a","fqdn":"ops-a.example.com","ipV4":"192.168.##.##","ipV6":[]}]}