vCenter Server UI and VAMI Inaccessible with ERR_SSL_PROTOCOL_ERROR After Upgrade to 8.0U3
search cancel

vCenter Server UI and VAMI Inaccessible with ERR_SSL_PROTOCOL_ERROR After Upgrade to 8.0U3

book

Article ID: 439917

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • After upgrading VMware vCenter Server to version 8.0U3 (e.g., build 8.0.3.00500), the vSphere Client UI and VAMI (:5480) are inaccessible.
  • Web browsers display the error: ERR_SSL_PROTOCOL_ERROR.
  • The vCenter appliance may not respond to pings on its assigned.
  • Logging into the vCenter shell reveals that services are running, network interface has correct IP address when checking ifconfig command

Environment

VMware vCenter 8.0U3 

Cause

This issue occurs when the vCenter Server appliance is running on an outdated virtual hardware version (e.g., Hardware Version 10). vSphere 8.0U3 introduces security and driver requirements that may not initialize correctly on legacy virtual hardware, leading to a failure in the network stack or SSL handshake protocols.

Resolution

Manual Procedure to Upgrade vCenter Virtual Hardware

To manually upgrade the hardware version for your vCenter appliance (e.g., from version 10 to 19 as in Case 36907311), follow these steps through the ESXi Host Client (since vCenter will be offline):

  1. Upgrade VM Hardware version:
    • Use vCenter console to locate the vCenter VM.
    • Right-click the vCenter VM in the inventory.
    • Select Compatibility and schedule compatibility upgrade.
  2. Power off the vCenter VM: shut off the vCenter appliance properly then power it back on
  3. Verify the version has upgraded for hardware version