Azure Logic Apps Integration Agent returns 408 Request Timeout
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Azure Logic Apps Integration Agent returns 408 Request Timeout

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Article ID: 439879

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When trying to configure execution in Azure Logic Apps, the workflow run starts successfully but encounters a problem at the monitoring stage.

2026-03-10 09:41:42 INFO: Workflow run started successfully. Workflow Run Id:0858...
2026-03-10 09:41:42 INFO: Monitoring started.
2026-03-10 09:41:44 INFO: Status : Running
2026-03-10 09:43:10 ERROR: Monitoring failed
2026-03-10 09:43:10 ERROR: Possible Reason: Request failed: 408 - Request Timeout

The agent closes the connection after not receiving a response for 50 seconds.

Environment

CA Automic Workload Automation - Automation Engine
Azure Logic Apps Integration Agent, 24.0.0

Cause

The polling frequency is hardcoded within the RA framework.  
The "408 Request Timeout" is an error generated by Azure, not UC4.  
Azure actively rejects and closes the connection because the Automic agent is hitting it with too many requests per second. Changing UC4's wait time will not stop Azure from blocking the overloaded requests

Resolution

This issue was found and fixed with the Integration.Azure.LogicApps 24.0.1 package. (Available)

Once the updated agent is installed and restarted, two new fields are added to the job configuration:

  1. Sleep Interval: (Optional) The interval between API interaction and Automic's processing during job monitoring defines how often Automic processes data after API interaction. For example, the interval can be set to 20 seconds. The default value is 1 second.  
  2. Failure Interval: The time interval, in seconds, before a job fails due to API failure