Compute Manager stuck in REGISTERED_WITH_ERRORS state due to a stale registration error from a DVS that no longer exists in vCenter
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Compute Manager stuck in REGISTERED_WITH_ERRORS state due to a stale registration error from a DVS that no longer exists in vCenter

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Article ID: 439836

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Updated On:

Products

VMware NSX

Issue/Introduction

  • In the NSX Manager UI, under [System] > [Fabric] > [Compute Manager], a Registration Error is displayed, and the following message can be observed.
    Failed to remove NSX ownership due to error Error in rest call. url= nsxapi/api//v1/managed-objects/switching/nsx-ownership/<CM_UUID>?action=clear , method= PUT , response= {  "details" : "com.vmware.nsx.management.common.exceptions.ObjectNotFoundException: The requested object : <DVS_ID> could not be found. Object identifiers are case sensitive.",  "httpStatus" : "BAD_REQUEST",  "error_code" : 8012,  "module_name" : "NsxSwitching service",  "error_message" : "Unable to clear NSX ownership from MO <CM_UUID>/<DVS_ID>."} , error= 400 : "{  "details" : "com.vmware.nsx.management.common.exceptions.ObjectNotFoundException: The requested object : <DVS_ID> could not be found. Object identifiers are case sensitive.",  "httpStatus" : "BAD_REQUEST",  "error_code" : 8012,  "module_name" : "NsxSwitching service",  "error_message" : "Unable to clear NSX ownership from MO <CM_UUID>/<DVS_ID>."}"

  • The following message can be found in /var/log/cm-inventory/cm-inventory.log within the NSX Manager log bundle.
    ...
    <Timestamp>  INFO inventoryTasksScheduler5 CmPluginStateManager 4452 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="cm-inventory"] CM <CM_UUID> mapped to this node and current status is discovered_resource {
      last_sync_time: <Timestamp>
    ...
    registration_error {
      error_message {
        value: "Failed to remove NSX ownership due to error Error in rest call. url= nsxapi/api//v1/managed-objects/switching/nsx-ownership/<CM_UUID>?action=clear , method= PUT , response= {\n  \"details\" : \"com.vmware.nsx.management.common.exceptions.ObjectNotFoundException: The requested object : <DVS_ID> could not be found. Object identifiers are case sensitive.\",\n  \"httpStatus\" : \"BAD_REQUEST\",\n  \"error_code\" : 8012,\n  \"module_name\" : \"NsxSwitching service\",\n  \"error_message\" : \"Unable to clear NSX ownership from MO <CM_UUID>/<DVS_ID>.\"\n} , error= 400 : \"{<EOL>  \"details\" : \"com.vmware.nsx.management.common.exceptions.ObjectNotFoundException: The requested object : <DVS_ID> could not be found. Object identifiers are case sensitive.\",<EOL>  \"httpStatus\" : \"BAD_REQUEST\",<EOL>  \"error_code\" : 8012,<EOL>  \"module_name\" : \"NsxSwitching service\",<EOL>  \"error_message\" : \"Unable to clear NSX ownership from MO <CM_UUID>/<DVS_ID>.\"<EOL>}\" .. Please resolve the error and try again."
      }
      timestamp: <Timestamp>
      error_code: 90325
    }
    reverse_proxy_http_port: 80
    server_cert_key_length {
      value: 3072
    }
    server_cert_algorithm {
      value: "RSA"
    }
    ...
  • The DVS with the ID mentioned in the message is not being used in the NSX Transport Node Profile and no longer exists on the vCenter side.

Environment

VMware NSX

Cause

This issue occurs because stale information regarding a previously used DVS persists within the NSX Manager's internal records.

Resolution

On the error screen visible in the NSX Manager UI, select the checkbox next to the error message and click the Resolve button. If the provided steps do not resolve the issue, contact Broadcom Support for further assistance.