The VCF Fleet inventory sync request is failing during the 'Push Capabilities to Operations-logs' stage, triggering error code LCMVRLICONFIG40119
search cancel

The VCF Fleet inventory sync request is failing during the 'Push Capabilities to Operations-logs' stage, triggering error code LCMVRLICONFIG40119

book

Article ID: 439805

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • Inventory sync request towards VCF Operations, VCF Operations for Logs and VCF Operations for Networks fails at Stage 3  "Push Capabilities to Operations-logs"  with below error:

    Error Code: LCMVRLICONFIG40119
    LCMVRLICONFIG40119
    java.net.ConnectException: Connection refused (Connection refused)



  • The VCF Fleet "/var/log/vrlcm/vmware_vrlcm.log" returns below error:

    java.net.ConnectException: Connection refused (Connection refused)  at org.springframework.http.HttpStatus.valueOf(HttpStatus.java:547)    at com.vmware.vrealize.lcm.plugin.vrli.serviceregistry.PushCapabilitiesToVrliTask.lambda$execute$0(PushCapabilitiesToVrliTask.java:134)    at com.vmware.vrealize.lcm.util.RetryUtil.retryFunction(RetryUtil.java:26)    atcom.vmware.vrealize.lcm.plugin.vrli.serviceregistry.PushCapabilitiesToVrliTask.execute(PushCapabilitiesToVrliTask.java:96)    at com.vmware.vrealize.lcm.automata.core.TaskThread.run(TaskThread.java:62)   at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)    at java.base/java.lang.Thread.run(Unknown Source)

Environment

VCF Operations 9.x
VCF Operations for Logs 9.x
VCF Operations for Networks 9.x
VCF Fleet Management 9.x

Cause

The VCF Operations for Logs FQDN was incorrectly set to localhost within the VCF Fleet Management Inventory.
This configuration state caused the Inventory sync to fail at the "Push Capabilities to Operations-logs" stage.

Note: Confirm the "operations-logs" component FQDN by navigating to the VCF Operations UI via Fleet Management > Lifecycle > VCF Management > Components and select "operations-logs".

Resolution

To update the correct FQDN details and resolve the sync failure, execute the following steps:

  1. Remove the "operations-logs" component from Fleet Management, explicitly deselecting the "Delete associated VMs from vCenter" option to retain the appliance data.



  2. Re-add the "operations-logs" component using the correct FQDN.

  • Navigate to Fleet ManagementLifecycle VCF ManagementComponents
  • Click on Add Component >> Select "operations-logs"
  • Choose Installation Type as Import.
  • Click Next and provide the required details.
  • Confirm the import is completed and also make sure "operations-logs" FQDN is updated correctly.

    3. Re-trigger the Inventory sync task from VCF Fleet Management.

Additional Information

Other articles that may be relevant if Inventory sync task is failing at Stage 3  "Push Capabilities to Operations-logs" and returns error code LCMVRLICONFIG40119

Inventory sync fails with Error code: LCMVRLICONFIG40119 for VCF Operations and VCF Operations for Networks.

Corrupted truststore of VCF Operations for Logs