vCenter ESXi host licensing usage does not match with total ESXi host cores
search cancel

vCenter ESXi host licensing usage does not match with total ESXi host cores

book

Article ID: 439772

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

You may observe that the vCenter ESXi host licensing usage displays a higher number of cores than the actual physical core count in the environment. For example, the vCenter licensing usage might show 908 cores, while the physical hosts only account for 836 cores.

 

Environment

  • VMware vCenter Server

  • VMware ESXi

Cause

This discrepancy occurs when there are "ghost" or stale ESXi hosts in the vCenter Server database that have been decommissioned but are still erroneously consuming license capacity.

Resolution

To identify and remove the decommissioned hosts consuming license capacity, follow these steps:

  1. Verify the actual core count in your environment by running the script provided in KB 313548.

  2. In the vSphere Client, navigate to Administration > Licensing > Licenses.

  3. Select the Assets tab, and then click Hosts.

  4. Click the Export button at the bottom of the table to export the total ESXi host usage report.

  5. Compare the exported vCenter report against the results of the script from step 1 to identify the stale or "ghost" hosts.

  6. Follow the steps outlined in Cleaning decommissioned ESXi host from vCenter Server license inventory (KB 416427) to remove the stale host information from the vCenter database.

Additional Information

Subscribe to this knowledge article to get updates on this issue.