Members of User Groups see "App Not Found" and Other Errors When Trying to Manage Apps in Tanzu Hub
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Members of User Groups see "App Not Found" and Other Errors When Trying to Manage Apps in Tanzu Hub

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Article ID: 439764

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Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

You see errors similar to the following when trying to manage applications in Tanzu Hub:

  • App Not Found
  • Unable to use app. Ensure that the app exists and you have access to it and the organization is not suspended.

Environment

Tanzu Hub

Cause

Hub doesn't support logging in with user groups configured in foundations yet. Even if the user group is mapped to a role such as cloud_controller.admin, the users of the group will not have the correct permissions.

Resolution

Assign the required roles to the users in Hub directly. Refer to the Manage Users documentation for the required roles and how to assign them