OPS3917S Catalog workarea too small for prefix xxxxxxx
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OPS3917S Catalog workarea too small for prefix xxxxxxx

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Article ID: 439762

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Updated On:

Products

OPS/MVS Event Management & Automation

Issue/Introduction

You are IPLing our Data center in a new Location. On the first LPAR OPS/MVS is not functioning to bring up tasks.

You have not seen any OPS messages indicating a failure in CAS9 or CAIRIM or OPS/MVS error statements

The following message appears in the OPSMAIN joblog:

OPS3917S Catalog workarea too small for prefix xxxxxxx

Environment

OPS/MVS

Cause

More than 2,500 datasets were matching the OPS/MVS RULEPREFIX parameter. From OPS/MVS documentation:

OPS3917S                                                             
   Catalog workarea too small for prefix var1                        
                                                                     
                                                                     
   Modifiable: Yes                                                   
                                                                     
   Explanation:                                                      
     The catalog contains more than 2500 data set entries whose names
     begin with the AOF rule data set prefix as specified by the     
     RULEPREFIX product parameter.  The work area used to contain the
     results of the catalog search cannot contain more than 2500 data
     set entries.                                                    
                                                                     

Resolution

Deleting some datasets to bring the number below 2,500 solved the problem.

From OPS/MVS documentation:

Action:                                                            
  Reduce the number of data sets under the rule data set prefix.   
  Doing so will significantly improve performance on AOF rule set  
  related operations.  We strongly recommend that you use a unique 
  high-level qualifier for your AOF rule data sets.  As a last     
  resort, if you are unable to reduce the number of data sets under
  the high level qualifier, contact CA Customer Support for        
  assistance in increasing the size of the CA OPS/MVS catalog work 
  area.                                                            

Additional Information

From case 36918554