Editing groups in Operator Console returns a blank white screen
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Editing groups in Operator Console returns a blank white screen

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Article ID: 439732

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When you attempt to edit specific groups within the UIM Operator Console (OC), the application displays a blank white screen.

Environment

  • UIM 23.4.x
  • OC 23.4.x

Cause

This issue may occur due to corruption in the cm_group database table. Specifically, the criteria field of the database record for the group may be missing the required attributes.

Resolution

-- WARNING!!!
-- Consult with your DBA before using these commands and do test it first in a UIM Test/DEV/Staging environment.  We highly recommend backing up tables before executing any updates or deletes.  Lost data is unrecoverable without a backup.

You must perform manual database cleanup to correct the corrupted criteria.  This is done by the following steps:

  1. Identify the affected group by its name.
    SELECT * FROM CM_GROUP WHERE name = '<GroupNameHere>'

    The grp_id field is the unique identifier for this group.  You'll use this value in the next step to remove the corruption.

    Note: if there are several groups with the same name, you may need to identify the group by the group contain it is in.  The pgrp_id field will tell you which container this group is in.

  2. Update the criteria field to remove the corruption.  Run the following SQL update (example for grp_id #### obtained in step 1):
    UPDATE CM_GROUP SET criteria=NULL WHERE grp_id=####;
  3. Return to Operator Console and edit the group.  You can now re-apply all criteria for this group as needed.

Additional Information

Broadcom assumes no liability for any issues arising from using these commands. Your DBA should evaluate the commands before executing them.