VMware Avi Load Balancer Upgrade Failure from 30.2.2 to 31.1.2 due to leading space in the pool name.
search cancel

VMware Avi Load Balancer Upgrade Failure from 30.2.2 to 31.1.2 due to leading space in the pool name.

book

Article ID: 439671

calendar_today

Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

  • The upgrade from version 30.2.2 to 31.1.2 fails.
  • The following error occurs during the migrate config task:
    • Failure: MigrateConfig: [Tue May 5 06:42:16 2026]Error while running task:MigrateConfig Unable to complete task MigrateConfig on ['node2.controller.local']. Traceback (most recent call last): File "/opt/avi/python/lib/avi/upgrade/upgrade_tasks.py", line 331, in start self.run() File "/opt/avi/python/lib/avi/upgrade/upgrade_tasks.py", line 595, in run self.run_remote_command(cmd, self.hosts) File "/opt/avi/python/lib/avi/upgrade/upgrade_tasks.py", line 574, in run_remote_command raise RuntimeError("Unable to complete task %s on %s." % (self.name, list(self.err_nodes.keys()))) RuntimeError: Unable to complete task MigrateConfig on ['node2.controller.local']. . (node2.controller.local)

       

  • To check further logs.

    • Login to shell mode on leader controller node
      # shell
      > show upgrade status details filter controller
      Error: Unable to complete task migrate_config on ['node.controller.local']
      
      # Logs to check on Controller Node
      /var/lib/avi/log/upgrade-coordinator.log
      Unable to complete task migrate_config on ['node.controller.local']
      
      # Example log:
      /var/lib/avi/log/task_journal/upgrade_import_config.json
      "details": [
                      "Serializing error {'non_field_errors': [ErrorDetail(string='The fields name, tenant_ref, cloud_ref must make a unique set.', code='unique')]} for PoolSerializer with data: {'uuid': 'pool-########-####-####-####-########', 'name': ' Testpool_name', 'default_server_port': 443, 

 

Environment

VMware AVI Load Balancer

Version: 30.2.2

Cause

  • This error is caused by the leading space in the pool name.
    • {'uuid': 'pool-########-####-####-####-########', 'name':' Testpool_name'}
    • # Example log:
      /var/lib/avi/log/task_journal/upgrade_import_config.json
      "details": [
                      "Serializing error {'non_field_errors': [ErrorDetail(string='The fields name, tenant_ref, cloud_ref must make a unique set.', code='unique')]} for PoolSerializer with data: {'uuid': 'pool-########-####-####-####-########', 'name': ' Testpool_name', 'default_server_port': 443,  

Resolution

  1. Login to the controller leader node UI.
  2. Search the pool name that has leading space in the name.
    1. On the controller UI.
      1. Go to Applications => Pools.
  3. Remove the leading space from the pool name.