Inaccessible vSAN Objects due to Deduplication Metadata Checksum Mismatch after Power Outage
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Inaccessible vSAN Objects due to Deduplication Metadata Checksum Mismatch after Power Outage

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Article ID: 439661

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Updated On:

Products

VMware vSAN

Issue/Introduction

Following a sudden power outage or improper shutdown, multiple virtual machines (VMs) on a vSAN cluster appear as Inaccessible or Invalid.

Specific indicators include:

  • vSAN health checks report Physical disk issue or vSAN object health: inaccessible.
  • Running esxcli vsan debug object health summary get confirms a significant number of inaccessible objects.
  • One or more disk groups fail to mount on specific hosts, even though physical hardware is reported as healthy.
  • esxcli vsan storage list shows In CMMDS: false for disks in the affected groups.

Environment

VMware vSAN 8.x

Cause

The issue is caused by a deduplication metadata inconsistency. During the power outage, the deduplication hash map (HMap) metadata experienced a Checksum mismatch. To prevent potential data corruption, vSAN prevents the entire disk group from mounting if it cannot verify the integrity of the deduplication metadata.

Log Evidence

Entries in vmkernel.log or boot.log will typically show:

  • WARNING: PLOG: DDPIsValidBlkHdr: PBN [Number], Checksum mismatch: saved [Value] computed [Value]
  • WARNING: PLOG: DDP_Recovery: Recovery Txn Replay failed Read error diskgroup [UUID]
  • WARNING: PLOG: PLOGDedupInit: Init DG failed for SSD [UUID] :Read error

Resolution

Please open a Broadcom Support request if you experience the above symptoms.