Port-channel is in stand-alone state in ESXi
search cancel

Port-channel is in stand-alone state in ESXi

book

Article ID: 439647

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

The Link Aggregation Group (LAG) status on the ESXi host displays as Stand-alone, preventing the expected port-channel formation and bandwidth aggregation.

[root@esx:~] esxcli network vswitch dvs vmware lacp status get

####:
   DVSwitch: ####
   Flags: S - Device is sending Slow LACPDUs, F - Device is sending fast LACPDUs, A - Device is in active mode, P - Device is in passive mode
   LAG ID: 1070836645
   Mode: Active
   Nic List:
            Local Information:
                  Admin Key: 19
                  Flags: SA
                  Oper Key: 19
                  Port Number: 2
                  Port Priority: 255
                  Port State: ACT,AGG,DEF,
            Nic: vmnic7
            Partner Information:
                  Age: 00:00:13
                  Device ID: 00:00:00:00:00:00
                  Flags: SP
                  Oper Key: 0
                  Port Number: 0
                  Port Priority: 0
                  Port State:
            State: Stand-alone

            Local Information:
                  Admin Key: 19
                  Flags: SA
                  Oper Key: 19
                  Port Number: 1
                  Port Priority: 255
                  Port State: ACT,AGG,DEF,
            Nic: vmnic6
            Partner Information:
                  Age: 00:00:13
                  Device ID: 00:00:00:00:00:00
                  Flags: SP
                  Oper Key: 0
                  Port Number: 0
                  Port Priority: 0
                  Port State:
            State: Stand-alone

Executing esxcli network vswitch dvs vmware lacp stats get shows Rx LACPDUs as 0, while Tx LACPDUs are incrementing.

DVSwitch    LAG ID      NIC     Rx Errors  Rx LACPDUs  Tx Errors  Tx LACPDUs
----------  ----------  ------  ---------  ----------  ---------  ----------
####        1070836645  vmnic7          0           0          0       16994
####        1070836645  vmnic6          0           0          0       16994

Environment

VMware vSphere ESXi

Cause

ESXi is not receiving LACP PDU from the peer switch.

Resolution

Ensure LACP is configured on the physical switch and it is sending LACP PDUs. Please ensure the following criteria is met.

  • The number of ports in the LACP port channel must be equal to the number of physical NICs that you want to group on the host. For example, if you want to aggregate the bandwidth of two physical NICs on a host, you must create an LACP port channel with two ports on the physical switch. The LAG on the distributed switch must be configured with at least two ports.
  • The hashing algorithm of the LACP port channel on the physical switch must be the same as the hashing algorithm that is configured to the LAG on the distributed switch.
  • All physical NICs that you want to connect to the LACP port channel must be configured with the same speed and duplex.

Please refer to Introduction to LACP in VMware by Broadcom for supported modes.

    Additional Information

    LACP Support on a vSphere Distributed Switch