vSphere Client を使用してサポートバンドルを生成するとルートパーティションの使用率が高くなる、または上限に達する
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vSphere Client を使用してサポートバンドルを生成するとルートパーティションの使用率が高くなる、または上限に達する

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Article ID: 439637

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Products

VMware vCenter Server

Issue/Introduction

  • 管理者は vCenter Server Appliance のルートパーティションで "Disk Space Low"、"Filesystem Full"、または "Root Disk Exhaustion" というアラートを確認します。

  • このアラートは、vSphere Client で「システムログのエクスポート」タスクが実行された際に発生します。

  • サポートバンドルがダウンロードされて削除されると、ルートパーティションの使用率は低下します。ただし、ダウンロードが失敗または継続する場合は、使用率は高いままとなります。

Environment

VMware vCenter Server

Cause

vSphere Client UI を使用してサポートバンドルを取得すると、vCenter Server はステージングディレクトリ "/etc/vmware-vpx/docRoot/diagnostics" にサポートバンドルを生成します。
このディレクトリはルートパーティション(/)にマウントされます。大規模な環境では、サポートバンドルのサイズが10GBを超える場合があります。
ルートパーティションが既に部分的に使用されている場合(例えば40~50%)、この大きな一時ファイルを追加すると、容量不足のアラームが発生したり、パーティションが完全にいっぱいになったりする可能性があります。

Resolution

既存のステージング済みバンドルを削除します

  1. SSH経由でrootユーザーとして vCenter Server に接続します。

  2. ステージングディレクトリに移動します: cd /etc/vmware-vpx/docRoot/diagnostics

  3. ファイル一覧を表示してサイズを確認します: ls -lh

  4. サポートバンドルを削除します。rm *.tgz

回避策

ファイルサイズが大きくなるサポートバンドルの生成にはCLIを使用します:ルートパーティションへの負荷を避けるため、コマンドラインを使用して、よりサイズの大きな/storage/coreパーティションを保存先としてサポートバンドルを生成します。

  1. vCenter Server に SSH で接続します。

  2. ログ収集コマンドを実行します。vc-support -w /storage/core

  3. コマンドの実行が完了したら、SCP/SFTPを使用して /storage/core に生成されたファイルをダウンロードします

Additional Information

Root partition reaches high utilization or fills up when generating Support Bundle via vSphere Client