VCF 9 Upgrade fails immediately on the NSX upgrade portion with error "System initiated upgrade cancel operation"
search cancel

VCF 9 Upgrade fails immediately on the NSX upgrade portion with error "System initiated upgrade cancel operation"

book

Article ID: 439625

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • When attempting to upgrade VCF 9 and the NSX portion of the upgrade it fails with the following error immediately after starting the upgrade "System initiated upgrade cancel operation"

  • Within the VCF Operations admin UI under Fleet Management --> Passwords --> VCF Integration the NSX instance shows one or more accounts (admin, audit, root) in a 'Disconnected' state

Environment

VMware Cloud Foundation 9.x

Cause

This issue occurs due to authentication failure(s) for one or more NSX accounts when attempting to start the NSX upgrade portion of the VCF upgrade. If authentication fails the system assumes NSX is unreachable and cancels the upgrade automatically. 

Resolution

Update or Remediate all the impacted accounts which are showing 'Disconnected' for the NSX Manager instance.

See Update Passwords for VMware Cloud Foundation Components and Remediate Passwords for VMware Cloud Foundation Components

After all NSX system accounts are successfully showing 'Connected' retry the VCF upgrade once again.