Monitor the ICMP probe when the metrics stop collecting
search cancel

Monitor the ICMP probe when the metrics stop collecting

book

Article ID: 439617

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We need assistance with exceptions from the ICMP logs when the ICMP probe stops collecting metrics or a proactive approach from the UIM application where we can proactively monitor the ICMP probe when the metrics stop collecting.

Environment

  • DX UIM 23.4 - any version

Cause

  • Alert when there is no qos being saved for the icmp probe

Resolution

Sample query that can be used:

SELECT
sd.probe,
sd.qos,
sd.source,
sd.target,
sd.r_table,
ss.sampletime,
ss.samplevalue
FROM S_QOS_SNAPSHOT
ss 
JOIN S_QOS_DATA sd ON ss.table_id = sd.table_id
WHERE ss.sampletime > DATEADD(hour, -24, GETDATE())
AND sd.probe = 'icmp';

Using sqlserver you can create and run an sql query and if there are any empty/null values in the results, using the configuration options->generate an alarm.