VCF Operations Business Console License Sync Failure with error “One or more licenses expire on <month_year>”
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VCF Operations Business Console License Sync Failure with error “One or more licenses expire on <month_year>”

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Article ID: 439522

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Updated On:

Products

VCF Operations VMware Cloud Foundation VMware vCenter Server

Issue/Introduction

VMware license keys are not syncing with the Broadcom License Portal. The VCF Operations Business Console displays the following error: "The due date for submitting your usage report is on .

To prevent service interruption, download a usage file and submit in the VCF Business Services console". Additionally, the vCenter UI may report "One or more licenses expire on <month_year>", despite the connection status in the business console showing no errors and the applied license appearing active.

Environment

VMware Cloud Foundation 9.x

VCF Operations 9.x

vCenter Server 9.x

Cause

The automated license usage synchronization is prevented by a transient network communication failure or an internet glitch between the <vCenter Server> and the VCF Business Services Console.

Resolution

  1. Attempt a standard synchronization by clicking the Update Licenses button in the UI. If this succeeds, the usage will update and no further action is required.
  2. If the standard synchronization fails, attempt a manual update: Download the usage file, generate a new Solution License File from the Business Console, and upload it.
  3. Try restarting vmware-cis-license on the vCenter node.
    • service-control --restart vmware-cis-license
  4. If the system fails to pick up the manually uploaded license file, disconnect the current registration and re-register.

If issue persists, kindly open a case with Broadcom Support for assistance.

Additional Information

In VMware Cloud Foundation (VCF) 9.0 and later, the license usage file and the resulting Solution License File are valid for 180 days. A mandatory update cycle is required:

  • Connected Mode: You must click the button to send in the license usage information within every 180-day cycle.
  • Disconnected (Air-Gapped) Mode: You must manually upload the license usage file to the Broadcom support portal and download the updated license file to VCF Operations within every 180 days to maintain compliance.