After re-installing the VCF Operations appliance 9.x , we are unable to assign licenses to the vCenter
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After re-installing the VCF Operations appliance 9.x , we are unable to assign licenses to the vCenter

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Article ID: 439370

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Updated On:

Products

VCF Operations VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When importing a license file via License Management > Registration, the license status remains 'Unregistered.'

  • The vCenter displays 0 cores under License Management > Licenses , preventing license assignment to the vCenter.

Environment

  • VCF Operations 9.x 

Cause

  • The issue is caused by a mismatch between the VCF Operations ID of the newly deployed appliance and the one registered in the Broadcom License Portal.
  • Each VCF Operations deployment generates a unique VCF Operations ID. If an older or stale instance from a previous deployment using the same VCF Operations FQDN remains active in the portal, it can interfere with the registration of the new appliance. As a result, the new instance stays in an “Unregistered” state and the license details do not appear in the license tables.

Resolution

  1. Log in to the VCF Business Services console.
  2. Deactivate the old instance of VCF OPS on the Business Services console
    Refer: How to deactivate a license currently assigned to a VCF Operations 9.0 instance.
  3. Register the new instance of VCF OPS
    Refer: Registering VCF Operations with the VCF Business Services console.
  4. Verify that the status transitions to "Registered" state and the license keys will now be visible under License Management > Licenses.
  5. You can successfully assign the license to the vCenter.