Newer VMware Kubernetes Service (VKS) versions not listed in VKS upgrade UI via vCenter
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Newer VMware Kubernetes Service (VKS) versions not listed in VKS upgrade UI via vCenter

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Article ID: 439327

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Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

  • Latest versions are not seen in the vCenter UI dropdown list when trying to upgrade VKS 
  • Only older versions are seen
  • Example:

Environment

  • VMware Kubernetes Service 
  • VMware vCenter Server 

Cause

  • This is expected behavior for asynchronous VKS releases 
  • The VKS version options that appear by default in the vCenter UI, are those that are embedded with the specific vCenter build (synchronous releases)
  • For asynchronous upgrades to newer VKS versions, a manual registration step is required

Resolution

  1. Register the new VKS version
    • Download the VKS package.yaml file for the latest version from the Broadcom Support Portal
    • In the vSphere Client, navigate to Supervisor Management > Services
    • On the Kubernetes Service tile, click Actions > Add New Version
    • Upload the downloaded VKS package.yaml file to register VKS version with vCenter

  2. Upgrade the VKS version
    • After the new version is registered, select Actions > Upgrade on the Kubernetes Service option
    • Choose the newly registered VKS version from the dropdown list and proceed with the upgrade