Job plan stuck in 'check pre conditions' due to missing JOBI permissions
search cancel

Job plan stuck in 'check pre conditions' due to missing JOBI permissions

book

Article ID: 439286

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

While running a job plan (workflow) that has a precondition set on one of its jobs, it becomes indefinitely stuck in the 'check pre conditions' status

 

Symptoms:

  • A Job Plan (Workflow) becomes stuck in the status "check pre conditions".

  • Reviewing the Work Process (WP) logs reveals "Access denied" messages for specific XC_INC objects

Environment

 

Product: CA Automic Workload Automation - Automation Engine

Version: 24.4.3

 

Cause

The user executing or monitoring the task lacks the necessary "Execute" permissions for Include (JOBI) objects required to process preconditions and actions within the engine.

 

Resolution

To resolve this issue, grant X - Execute permissions to the affected User/UserGroup for the following objects:

  • JOBI: XC_INC.ACTION.SKIP_TASK
  • JOBI: XC_INC.ACTION.RUN_TASK
  • JOBI: XC_INC.CONDITION.USER_DEFINED

 

Recommendation:

Instead of adding these individually, you can provide broader access by adding X - Execute permissions for the following mask:

  • JOBI: XC_INC.*

Additional Information

If problems persist, it's recommended to review the Work Process (WP) logs to find "Access denied" messages that occur when you run your workflow/jobp and experience this problem. The messages should reveal what additional permissions are needed. 

Example message:

  • 20260430/210648.959 - U00000009 'XC_INC.ACTION.RUN_TASK': Access denied
  • 20260430/210617.070 - U00000009 'XC_INC.ACTION.SKIP_TASK': Access denied
  • 20260430/210547.843 - U00000009 'XC_INC.CONDITION.USER_DEFINED': Access denied