Error "[InstallerUI] Unable to fetch the share folder path" in EEM installation log file
search cancel

Error "[InstallerUI] Unable to fetch the share folder path" in EEM installation log file

book

Article ID: 439285

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager ServiceDesk CA Service Catalog

Issue/Introduction

EEM is installed to the E: drive and is working correctly.

After trying upgrade in place, EEM won't start.  The <EEM Installation Folder>\eiam-install.log file shows an error like this:

ERROR [main] [InstallerUI] Unable to fetch the share folder path

 

Environment

Service Desk v17.4.x
ITPAM v4.4.x
EEM v12.6.x and v12.7.x
Windows server (especially 2019 and 2022)
Since Service Catalog v17.4.x also integrates with EEM, this could also be seen when using Service Catalog

Cause

This error is common when the installation media is on a mounted ISO that becomes disconnected during a silent or interactive install EEM installation fails under D:\Program Files.

Resolution

To resolve this issue, follow these steps:

  1. Restore the server to its pre-upgrade status using a system snapshot or full backup.
  2. Proactively back up the following EEM installation folders:
    • ...\CA\SC\EmbeddedEntitlementManager
    • ...\CA\SC\iTechnology
    • ...\CA\Directory
    • ...\CA\SC\CAPKI
  3. Copy the installation media (ISO contents) to a local physical drive on the server.
  4. Restart the installation from the local drive.

Additional Information

A best practice is to always to make a full backup of your EEM installation folders by using one of these two methods

  • Zip the following folders and/or copy them to another location
    • ...\CA\SC\EmbeddedEntitlementManager,
    • ...\CA\SC\iTechnology,
    • ...\CA\Directory,
    • ...\CA\SC\CAPKI

  • Take a snapshot of the server, just before upgrading EEM.  Restoring from the backup is the most effective way to recover if an error occurs during upgrade.

EEM installation files are on the download ISO image for Service Desk, found on the Broadcom Support Website here: CA Service Management - Service Desk Manager