Alert: "Adapter Instance Object is Down" on the VCF Diagnostics Adapter in VCF Operations
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Alert: "Adapter Instance Object is Down" on the VCF Diagnostics Adapter in VCF Operations

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Article ID: 439238

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Updated On:

Products

VCF Operations

Issue/Introduction

Recurring alerts about VCF Diagnostics Adapter Instance is down triggered on VCF Operations 

Adapter Instance Object is Down

In the adapter logs (/storage/vcops/log/adapters/Diagnostics Adapter) on the node where the alert triggers shows:

[35054] com.vmware.adapter3.diagnostics.exception.DiagnosticsRuntimeException: java.security.GeneralSecurityException: Failed to read private key
[35055] 	at com.vmware.adapter3.diagnostics.endpoints.NSXTEndpoint.toHostConfig(NSXTEndpoint.java:60) ~[DiagnosticsAdapter3.jar:?]
[35056] 	at com.vmware.adapter3.diagnostics.collector.configuration.SkylineConfigurationManager.generateEndpoint(SkylineConfigurationManager.java:97) ~[DiagnosticsAdapter3.jar:?]
[35057] 	at com.vmware.adapter3.diagnostics.collector.configuration.SkylineConfigurationManager.reloadConfigurations(SkylineConfigurationManager.java:87) ~[DiagnosticsAdapter3.jar:?]

Environment

VCF Operations 9.0.x 

Cause

The issue is caused by an invalid or incorrectly configured NSX-T Client Certificate within the NSX-T adapter credentials. The adapter is unable to read the private key associated with the provided certificate, preventing the connection to the NSX-T endpoint.

Resolution

To resolve this issue, refresh the NSX credentials in VCF Operations by providing valid Client Certificate data.

Workaround:

As an alternative, if valid client certificate data is unavailable to update the NSX Client Certificate Credentials, change the credential kind to use NSX Credentials by following these steps:

  1. Log in to the VCF Operations as admin.

  2. Navigate to Administration > Integrations > VCF Adapter.

  3. Select the NSX-T tab here.

  4. Click the Edit (pencil) icon.

  5. Under the Credential section, click the edit icon or create a new credential.

  6. Change the credential type to use standard NSX Credentials (Username/Password) instead of the Client Certificate.

  7. Click OK and then Save.

  8. Cancel the old alerts and wait for one collection cycle (default 5 minutes) to finish 

  9. The issue should be resolved now. 

Additional Information

Both standard 'NSX credentials' and 'NSX Client Certificate Credentials' are valid credential types for this integration. For comprehensive instructions, please refer Configuring the NSX Account in VCF Operations.