Unable to complete sync for catalog error in VMware Cloud Director
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Unable to complete sync for catalog error in VMware Cloud Director

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Article ID: 439231

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • VMware Cloud Director (VCD) contains a catalog that is subscribed to a VMware vCenter content library.
  • One or more templates in the source library are replaced by new templates possessing the same name.
  • Attempting to synchronize the subscribed VCD catalog results in an error similar to the following:

    Unable to complete sync for catalog

  • This behavior was not occurring previously and the VCD environment was recently updated to 10.6.1.1 or above.

Environment

VMware Cloud Director 10.6.1.x

Cause

If a template is replaced with an item possessing an identical name, VMware Cloud Director still attempts to identify the template using the previous identifier, which produces an error.

Resolution

This is a known issue that affects VMware Cloud Director (VCD) 10.6.1.1 or above and there is no resolution.

In order to work around this behavior, there are several viable approaches to either mitigate the error before it occurs or remediate it afterwards, including the following:

  • Before the occurrence of the issue:
    • Option 1: Use the Update Item on the source content library item instead of recreating it, so that it will continue to use the original identifier.
    • Option 2: Create new versions of the templates with a different name than the originals.

  • After the occurrence of the issue:

    • Option 1: Delete and recreate the subscribed catalog in VCD.
    • Option 2: Perform the following steps:
      1.  Remove the problematic items from the source library.
      2. Synchronize the catalog from VCD.
      3. Re-introduce the items.
      4. Synchronize the catalog once more.