VCF Operations Sync Inventory encounters "Failed to get domain details" error
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VCF Operations Sync Inventory encounters "Failed to get domain details" error

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Article ID: 439148

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Updated On:

Products

VMware SDDC Manager VCF Operations

Issue/Introduction

  • When attempting to sync inventory in VCF Operations for any Workload or Management domain by navigating to VCF Ops > Inventory > VCF instances , the task encounters below error and does not allow to proceed:
    Failed to get domain details


  • On the VCF Operations Manager, entries similar to below are observed on /usr/lib/vmware-vcops/user/log/web-vcf.log pointing to communication issue to SDDC Manager:

    YYYY-MM-DDThh:mm:ss ERROR web-vcf 1##1 [ops@4##3 threadId="5##1" threadName="ajp-nio-127.0.0.1-8##9-exec-2#0"] [com.vmware.vcf.operations.ui.proxy.ProxyUtil.error] - Error occurred while serving the path: vcf-operations/plug/sddc-108/plugin/ops-plugin/index.html.
    YYYY-MM-DDThh:mm:ss ERROR web-vcf 1##1 [ops@4##3 threadId="5##1" threadName="ajp-nio-127.0.0.1-8##9-exec-2#0"] [com.vmware.vcf.operations.ui.proxy.ProxyUtil.error] - No route to host 

  • Concurrently, the SDDC Manager UI is found to be inaccessible.

Cause

A communication failure occurs between VCF Operations and the SDDC Manager because the SDDC Manager is unresponsive. VCF Operations relies on API calls to fetch domain details from the SDDC Manager, which fail when the SDDC Manager services are unavailable.

Resolution

To resolve the issue restore communication between SDDC Manager and VCF Operations Manager by following below steps

  1. Verify the accessibility of the SDDC Manager UI and API by reviewing Confirm there are no underlying SDDC Manager service or capacity issues by referencing Troubleshooting SDDC Manager UI access Issues.

  2. Verify network connectivity between VCF Operations and the SDDC Manager. Ensure that forward and reverse DNS resolution is functioning correctly and that required communication ports (such as port 443) are open and not blocked by an intervening firewall.

  3. Reboot the SDDC Manager appliance to restore connectivity and services.

  4. Navigate back to VCF Ops > Inventory > VCF instances > WLD or Mgmt domain and re-initiate the Sync Inventory task.