ESXi 9.x reporting error, "lost #### log messages" due to vmsyslogd not logging.
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ESXi 9.x reporting error, "lost #### log messages" due to vmsyslogd not logging.

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Article ID: 438980

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Updated On:

Products

VCF Operations

Issue/Introduction

Customer is getting constant emails about "lost ##### log messages" from all hosts.

This email is to notify you that an alarm has been triggered in your vCenter:
Alarm alarm.HostErrorAlarm on Host xxxxx.xxxx.com because Issue detected on xx-vcf-esx-01.xxxxx.com in xx-xx-dc01: vmsyslog logger xx.xx.xx.xxx:xxxx lost 462550 log messages 

The vmkernel and vmkwarning logs show the messages:

2026-04-12T20:54:24.309Z Al(177) vmkalert: cpu13:2097661)ALERT: vmsyslog logger xx.xx.xx.xxx:xxxx lost 465067 log messages
2026-04-13T08:54:24.838Z Al(177) vmkalert: cpu28:2097661)ALERT: vmsyslog logger xx.xx.xx.xxx:xxxx lost 465081 log messages

Environment

VCF 9 

Cause

After the hosts were rebooted they had stopped logging to vmksyslogd.log.

Resolution

See the following KB for resolution: 

ESXi host logs not updating despite no errors observed  

  • Connect to the ESXi host via SSH
  • Check the watchdog and vmsyslogd process IDs (PIDs)by running the command:

ps -Cc|grep vmsyslogd

  • You see output similar to:

1234 1234  vmsyslogd  /bin/python /usr/lib/vmware/vmsyslog/bin/vmsyslogd.pyc -i

5678 5678  wdog-5678  /bin/python /usr/lib/vmware/vmsyslog/bin/vmsyslogd.pyc -i

  • Run the kill command for the watchdog process first and then the vmsyslogd process: 

kill -9 5678

kill -9 1234

  • Restart the vmsyslogd process by running the command:

/usr/lib/vmware/vmsyslog/bin/vmsyslogd

or

/etc/init.d/vmsyslogd restart

  • Then check the vmksyslogd.log to make sure that it is logging with the current date.