Deleting SNAT rules on a Tier-1 router via NSX-T Manager API
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Deleting SNAT rules on a Tier-1 router via NSX-T Manager API

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Article ID: 438895

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Updated On:

Products

VMware NSX

Issue/Introduction

TKGI created SNAT rules cannot be deleted within the VMware NSX (formerly NSX-T) user interface. Deletion of specific SNAT rules requires direct execution via the NSX Manager REST API.

Environment

VMware NSX

Cause

The NSX user interface prevents the deletion of TKGI-managed SNAT rules, requiring direct API intervention to work around this limitation.

Resolution

It is not recommended to delete the SNAT rule via API without consulting Broadcom Support. Therefore, please raise a support request under NSX to have the issue reviewed and receive assistance.


Note: Please consult the TKGI team and confirm that the SNAT rule can be safely deleted before raising a ticket with the NSX support team.

Additional Information

Creating and managing Broadcom support cases