EDAA service queries fail when using Smarts CAS via curl due to Service Ticket timeout
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EDAA service queries fail when using Smarts CAS via curl due to Service Ticket timeout

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Article ID: 438735

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Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

Symptoms

When testing the EDAA service with Central Authentication Service (CAS) in Smarts via curl commands, the following symptoms may be observed:

  • Successful acquisition of a Service Ticket (ST).
  • No response or error from the SAM domain when querying for notifications, even though alarms are present.
  • The issue occurs during manual testing where multiple curl commands are executed sequentially.

Environment

All Supported Smarts releases

Cause

By default, the Smarts CAS Service Ticket (ST) has a timeout of 10 seconds. When running queries manually via curl, the time taken to copy, paste, and execute subsequent commands often exceeds this 10-second window, rendering the ST invalid before it can be used

Resolution

For production or repetitive use, it is highly recommended to use automated scripts. Within a script, the authentication and resource access typically occur within the 10-second timeframe, avoiding expiration issues

For more details on authenticating against EDAA using Smarts CAS via command-line tools, refer to KB-425801