vCenter update fails at with error "Exception occurred in postInstallHook for B2B-patching"
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vCenter update fails at with error "Exception occurred in postInstallHook for B2B-patching"

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Article ID: 438672

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The vCenter patch failed with the following error: “Installation Failed – Exception occurred in postInstallHook for B2B-patching. Please check the logs for more details. Take corrective action and then resume.”

  • In vCenter /var/log/vmware/applmgmt/PatchRunner.log the following entries are seen.

[YYYY-MM-DDTHH:MM:SS] INFO service_manager Service vmware-stsd reported status stopped. Expected status started
[YYYY-MM-DDTHH:MM:SS] ERROR service_manager Service cannot be started. Error: Error executing start on service sts. Details {
    "detail": [
        {
            "id": "install.ciscommon.service.failstart",
            "translatable": "An error occurred while starting service '%(0)s'",
            "args": [
                "sts"
            ],
            "localized": "An error occurred while starting service 'sts'"
        }
    ],
    "componentKey": null,
    "problemId": null,
    "resolution": null
}
Service-control failed. Error: {
    "detail": [
        {
            "id": "install.ciscommon.service.failstart",
            "translatable": "An error occurred while starting service '%(0)s'",
            "args": [
                "sts"
            ],
            "localized": "An error occurred while starting service 'sts'"
        }
    ],
    "componentKey": null,
    "problemId": null,
    "resolution": null
}


[YYYY-MM-DDTHH:MM:SS] ERROR vmware_b2b.patching.phases.patcher Patch hook Patch got unhandled exception.
Traceback (most recent call last):
  File "/storage/seat/software-updateuth5jdpf/stage/scripts/patches/py/vmware_b2b/patching/phases/patcher.py", line 208, in patch
    _patchComponents(ctx, userData, statusAggregator.reportingQueue)
  File "/storage/seat/software-updateuth5jdpf/stage/scripts/patches/py/vmware_b2b/patching/phases/patcher.py", line 89, in _patchComponents
    _startDependentServices(c)
  File "/storage/seat/software-updateuth5jdpf/stage/scripts/patches/py/vmware_b2b/patching/phases/patcher.py", line 56, in _startDependentServices
    serviceManager.start(depService)
  File "/storage/seat/software-updateuth5jdpf/stage/scripts/patches/libs/sdk/service_manager.py", line 909, in wrapper
    return getattr(controller, attr)(*args, **kwargs)
  File "/storage/seat/software-updateuth5jdpf/stage/scripts/patches/libs/sdk/service_manager.py", line 799, in start
    super(VMwareServiceController, self).start(serviceName)
  File "/storage/seat/software-updateuth5jdpf/stage/scripts/patches/libs/sdk/service_manager.py", line 665, in start
    raise IllegalServiceOperation(errorText)
service_manager.IllegalServiceOperation: Service cannot be started. Error: Error executing start on service sts. Details {
    "detail": [
        {
            "id": "install.ciscommon.service.failstart",
            "translatable": "An error occurred while starting service '%(0)s'",
            "args": [
                "sts"
            ],
            "localized": "An error occurred while starting service 'sts'"
        }
    ],
    "componentKey": null,
    "problemId": null,
    "resolution": null
}
Service-control failed. Error: {
    "detail": [
        {
            "id": "install.ciscommon.service.failstart",
            "translatable": "An error occurred while starting service '%(0)s'",
            "args": [
                "sts"
            ],
            "localized": "An error occurred while starting service 'sts'"
        }
    ],
    "componentKey": null,
    "problemId": null,
    "resolution": null
}

Environment

 VMware vCenter Server 8.x

Cause

This issue is caused by a broken Security Token Service (STS) pipeline, often triggered by expired or invalid STS signing certificates, or stale machine account credentials and passwords.

Resolution

Note: Take a snapshot without memory of the standalone vCenter server. If in linked mode, take powered-off snapshots of all vCenter servers in the same Single Sign-On (SSO) domain.

  1. Select Rollback to the previous version.
  2. Run the vCert utility.
  3. Select Option 3: Manage Certificates.
  4. Select Option 8: STS Signing Certificates.

Once the STS certificate is replaced, restart the update.