"Virtual machine CPU usage" alarm continuously triggered on Avi Service Engine VMs in vSphere Client
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"Virtual machine CPU usage" alarm continuously triggered on Avi Service Engine VMs in vSphere Client

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Article ID: 438582

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

vCenter reports high CPU utilization of an Advanced Load Balancer (Avi) Service Engine (SE) virtual machine, while the Avi user interface reports significantly lower CPU utilization.

Environment

VMware Avi Load Balancer
VMware vCenter Server
VMware vSphere ESXi

Cause

This disparity in CPU utilization is by design. 

The Avi data path (se_dp) utilizes Data Plane Development Kit (DPDK) Poll Mode Drivers (PMD). The SE continuously polls the network interface queues for incoming packets, which keeps the vCPU continuously active at the hypervisor level. This causes ESXi to accurately report the vCPU as executing instructions 100% of the time, though it is executing an empty polling loop. This is expected architectural behavior and a false positive regarding actual data plane load.

More information, see Reasons for Hypervisor Reporting High CPU Utilization by SE and Disparity in CPU Utilization.

Resolution

To resolve the continuous alert generation for this expected behavior, disable the Virtual Machine CPU usage alarm for the specific Avi SE VMs in the vSphere Client:

  1. Log in to the vSphere Client.

  2. Navigate to the specific Avi Service Engine VM in the inventory.

  3. Select the Configure tab, then click Alarm Definitions.

  4. Locate the "Virtual machine CPU usage" alarm.

  5. Select the alarm and disable it for this specific object.

Alternatively, place all Avi SE VMs in a dedicated VM folder and disable the alarm at the folder level to apply it universally to all SEs.

Additional Information

vCenter and vRNI Report 100% NSX-T Edge CPU Utilization but Edge vCPUs are not fully utilized