Server Installation Failure During ParityServer Service Registry
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Server Installation Failure During ParityServer Service Registry

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Article ID: 438522

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

When installing or upgrading the App Control server, the installer fails at the point of registering the parityserver service. 

  • C:\program files (x86)\bit9\parityserver\support\serverinstall.log or C:\program files\bit9\parityserver\support\serverinstall.log 
    SHEPHERD: Creating Carbon Black App Control Server service.
    SHEPHERD: Executing "C:\Program Files\Bit9\Parity Server\parityserver.exe" /register /dsn "C:\Program Files\Bit9\Parity Server\shepherd.dsn"
    SHEPHERD: Return Code: 1 on execution of "C:\Program Files\Bit9\Parity Server\parityserver.exe".
    SHEPHERD: (FAILURE) Could not register Carbon Black App Control service.

Environment

  • Carbon Black Application Control: All Versions

Cause

  • Incorrect user permissions
  • Security application conflict

Resolution

  1. Uninstall Carbon Black Application Control.
  2. Delete left over product folders :
    C:\program files (x86)\bit9
    C:\program files\bit9
  3. Validate these registries do not exist 
    hklm\software\bit9
    hklm\services\currentcontrolset\parityserver
    hklm\services\currentcontrolset\parityreporter
  4. Validate user permissions. Permissions Required for the App Control Service Account
  5. Disable installed security products during the installation. 
  6. Disable tamper protection for the App Control Agent. 
  7. Attempt the Server installation again as a local administrator with DB access.