Control plane Not Active
search cancel

Control plane Not Active

book

Article ID: 438518

calendar_today

Updated On:

Products

VMware Telco Cloud Automation VMware Telco Cloud Platform

Issue/Introduction

The Control Plane shows as not active, and we cannot run the upgrade

Environment

TCA: 3.4

TCP: 5.1

Cause

A failed upgrade, or an upgrade performed outside of the TCA interface

Resolution

Set the Cluster to Active by updating the appropriate cluster ID psql entry to Active

  1. In the TCA Web UI, click the relevant cluster link. You can then find the Cluster ID displayed within your browser's URL.

  2. Look at the URL in the browser for the cluster ID ########-####-####-####-############

  3. SSH into the TCA Manager appliance and run the following, updating the cluster ID from step 3
    PGPASSWORD=$(cat /common/pgsql/passwords/tca_admin) psql -U tca_admin -d tca -c "select * from \"K8sClusterDetails\" where val->>'id'='########-####-####-####-############' and val->>'rowType'='cluster';" > /tmp/pg._query.txt
     
    
    PGPASSWORD=$(cat /common/pgsql/passwords/tca_admin) \
    psql -U tca_admin -d tca -c \
    "UPDATE \"K8sClusterDetails\"
     SET val = jsonb_set(val, '{status}', '\"ACTIVE\"', false)
     WHERE val->>'id'='########-####-####-####-############'
       AND val->>'rowType'='cluster';"


  4. Refresh the UI, showing the cluster as ACTIVE

  5. Run the upgrade

  6. If the upgrade button is not accessible, follow Restart management cluster upgrade