Auto tickets not working
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Auto tickets not working

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Article ID: 438515

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Updated On:

Products

DX SaaS

Issue/Introduction

Auto ticketing is not working and Gateway logs show the following error repeatedly:

[pool-1-thread-2] ERROR c.c.d.i.o.pollers.NewAlarmsPoller - Exception caught while automatic ticket creation Alarm Id - "Number" : com.ca.dxi.common.action.svdsk.NimAdapterException: Nim Error : Error from MDR:{"status":"400","message":"com.ca.sdm.dal.PersistenceException: INVALID: Message."}
 

Environment

DX O2 SaaS

Cause

The error code is 400: bad data. The error message translated to "This category requires the completion of the Configuration Item."

This likely caused ticketing to be skipped for other Alarms in the batch. 

Resolution

The fix for this behavior has been released in 26.2.1 SaaS rollout, which will enable ticket creation for other alarms.
Please download and use the latest DX Gateway.