MABS Backup Fails with FileFaultFault Error on vSAN Datastores
search cancel

MABS Backup Fails with FileFaultFault Error on vSAN Datastores

book

Article ID: 438485

calendar_today

Updated On:

Products

VMware vSAN 8.x VMware vSphere ESXi 8.0

Issue/Introduction

When attempting to back up virtual machines (VMs) residing on a vSAN datastore using Microsoft Azure Backup Server (MABS), the backup fails during the consistency check or replica creation phase.

The following error is reported in the backup solution: DPM encountered error from VMware while trying to get ChangeTracking information. Server - [HOSTNAME] ErrorCode - FileFaultFault (ID 33621 Details: Internal error code: 0x80990EF3)

In the ESXi /var/log/hostd.log similar to entries like:

  • Cannot compute changes for disk ...vmdk: Unknown change epoch.
  • DISKLIB-CTK : Could not open tracking file ...-ctk.vmdk.
  • Change tracking information is not available for ...vmdk: Could not open or create change tracking file.
  • The log may also reference a path ending in vmfs/volumes/vsan:################/####################################/FQDN_VM_clone_#-flat.vmdk on a vSAN datastore.

Environment

  • VMware vSAN 8.x 

  • VMware vSphere ESXi 8.0 

Cause

The issue is caused by an unsupported VM configuration on the vSAN datastore. The affected VMs are using legacy flat VMDK files and VMFS formats (e.g., VM-NAME-flat.vmdk).

Resolution

To resolve this issue, the virtual machine disk configuration must be corrected to use standard vSAN objects instead of flat files.

  1. Identify Affected Disks: Review the VM configuration and datastore files to identify any disks using the -flat.vmdk format.
    For more information on why flat files are unsupported, see Flat VMDK on vSAN - Unable to power on the VM.