Host name conflict check for the virtual machine" fails during Aria Operations upgrade pre-validation
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Host name conflict check for the virtual machine" fails during Aria Operations upgrade pre-validation

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Article ID: 438450

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When performing a pre-validation check for an Aria Operations upgrade via VMware Aria Suite Lifecycle (vRSLCM), the process fails.

  • The precheck details show a Failed status for the task: "Host name conflict check for the virtual machine."

  • From the Aria Suite Lifecycle Manager logs at /var/log/vrslcm/vmware.vrslcm.log we see these errors.
    • [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- DNS output:  server can't find [REDACTED-IP].in-addr.arpa: nxdomain
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- Host name got after resolving ... null
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- DNS output: [REDACTED-IP].in-addr.arpa name = [REDACTED-VM-FQDN].
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- Host name got after resolving ... [REDACTED-HOSTNAME-CAPS]
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- Executing process with command :: [nslookup, [REDACTED-VM-FQDN], [REDACTED-DNS-IP]]
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- DNS output: Server: [REDACTED-DNS-IP]
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- DNS output: Address: [REDACTED-DNS-IP]#53
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- DNS output:  server can't find [REDACTED-VM-FQDN]: nxdomain
      [REDACTED-TIME] INFO vrlcm[1342] [pool-3-thread-17] [c.v.v.l.u.SshUtils] -- Ip address got from reverse lookup :: null

Environment

  • VMware Aria Suite Lifecycle (vRSLCM) 8.x

  • VMware Aria Operations 8.x / 9.x

Cause

This issue occurs due to a hostname format and case-sensitivity mismatch between the Domain Name System (DNS), the Aria Operations appliance OS, and what Aria Suite Lifecycle expects.

Aria Suite Lifecycle attempts to resolve the Aria Operations node using a lowercase Fully Qualified Domain Name (FQDN). If the Aria Operations appliance is configured with a shortname, or if the DNS records and appliance hostname are configured using uppercase letters (ALL CAPS), the resolution fails, triggering the host name conflict error.

Resolution

To resolve this issue, you must standardize the DNS entries to lowercase and update the Aria Operations appliance to reflect the correct FQDN.

Step 1: Correct DNS Entries

  1. Access your DNS server.

  2. Locate the Forward (A) and Reverse (PTR) lookup records for the affected Aria Operations nodes.

  3. Ensure the hostnames are configured using all lowercase letters and represent the full FQDN.

  4. Verify the changes have propagated by running an nslookup for both the IP and the FQDN.

Step 2: Update the Aria Operations Node Hostname You will need to update the guest OS hostname to match the lowercase FQDN. Follow the instructions provided in the Broadcom KB article: How to change a node hostname in Aria Operations to change the hostname.

Step 3: Retry Aria Suite Lifecycle Tasks

  1. Return to VMware Aria Suite Lifecycle.

  2. Retry the upgrade pre-check.